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Ticket-it performance is very slow 

 

If Ticket-it performance is consistently slow (not a temporary issue), then try these solutions: 

 Update Internet Explorer on the affected computers. 

 Clear the cache and history of Internet Explorer on the affected computers. 

 Check proxies and hosts. Often your IT may have imposed restrictions on your internet that can cause 

problems for Ticket-it. 

 Reset Internet Explorer’s settings. Doing so will require pop-ups to be enabled for the Ticket-it website 

again, as well as accepting the ‘allow advanced printing’ prompt under the Ticket-it administration page. 

Note that if you have slow internet, Ticket-it will take a long time to load as a result.  

 

Pages print on a different printer 

This will occur if you selected the wrong “Virtual USB Port” during installation. To fix: 

 Right-click the printer icon and select Properties 

 Click the Ports tab.  

 Your Ticket-It printer’s name will appear alongside the port it’s currently assigned to. Other printers will 

also appear in this list, allowing you to determine which ports are free. Tick an alternate ‘Virtual Printer 

port for USB’ (generally the correct one will have no other printer assigned to it). 

 Try a test print to confirm. 

 Alternatively, delete the printer, and install it again; specifying a free port. 

 

The printer occasionally feeds extra labels or 

jams 

Most printers will exhibit strange printing behaviour if the label roll isn’t loaded properly or gets stuck during 

print, so it’s always worth checking for these factors: 

 Printer power cable is loose 

 Label roll inside the printer has fallen off the spindle or is slightly loose 

 Label roll inside the printer has not been correctly placed under the guides 

 Sticky residue on the roller or print-head. This can be rubbed off with a tissue or fingernail. 
 
 

 

 

http://support.microsoft.com/kb/923737


 

   

Label appears on screen but does not 

disappear or print 

There are two possible causes for this issue: 

1. When this occurs you should see the warning symbol in the bottom-left of your screen (see below 

screenshot). Clicking the warning symbol should show the above error message. 

To resolve this issue, uninstall the currently installed printer driver and install the recommended driver, 

using the instructions available at the Help Centre.  

 

 
 

2. You may need to downgrade Internet Explorer. At time of writing, Internet Explorer 11 is not supported. 

To downgrade: 

a. Open Programs and Features via the Start Menu, Start Screen or from Control Panel. 

b. Click View Installed Updates and let the page populate. 

c. Select Internet Explorer 11 under the Microsoft Windows header. 

d. Click Uninstall (near the top of the screen). Follow the prompts and reboot when required. 

e. You will then need to install the ActiveX again and unblock popups. 

  

http://www.courierpost.co.nz/faq/ticket-it-help/


 

   

The barcode is not correctly aligned 

Try changing the Page Length of the Page Size / Stock from 174 to 176/178mm. Instructions for setting up these 

sizes are included in the printer install guides available at the Help Centre. 

 

Labels print upside down 

If using the Seagull Drivers: 

1. In Control Panel -> Printers and Faxes / Devices and Printers, right-click the icon for your Ticket-it printer 
and select Printing Preferences.  

2. Click the Page Setup tab. 

3. Click the Advanced Options button. 

4. Select 180° in the Default Orientation listbox. Click Apply and OK. 

5. Click Apply and OK on the Page Setup tab as well. 

Note: There is another method for changing orientation using these drivers, but that option only functions 

correctly in Windows XP.  

If using the default Drivers: 

1. In Control Panel -> Printers and Faxes / Devices and Printers, right-click the icon for your Ticket-it printer 
and select Printing Preferences.  

2. In the Stocks listbox, select the Stock Size in use for Ticket-it. Normally this will be called “Ticket-it”. 

3. Tick Rotate 180°. 

4. Click Apply. 

If this has no effect, try: 

1. In Control Panel -> Printers and Faxes / Devices and Printers, right-click the icon for your Ticket-it printer 
and select Printing Properties.  

2. Click the Printer Settings tab. 

3. Tick Always use drivers settings. 

4. Click Apply. 

Finally, if the above still doesn’t work, recalibrate the printer. After doing this, you may need to untick the 180° 

option. 

 

“c:\mcfxuser.exe is missing” error when 

printing or viewing Administration tab 

To resolve this error, manually install the ActiveX component.  

http://www.courierpost.co.nz/faq/ticket-it-help/


 

   

Ticket-it prints an older label instead 

1. Open Internet Explorer. 
2. On the menu, select Tools -> Internet Options. You may need to press alt to reveal the menu. 
3. Click the Settings button. 
4. Tick Automatically under the Check for newer versions of stored pages header. 

 

 
 

Odd Black Boxes appear on the ticket 

This tends to occur if you’ve upgraded Internet Explorer or migrated to a new system. The solution is to reinstall 

the ActiveX component.  

 

 

 



 

   

The printed Ticket image is too small/large 

to fit on the label 

There is a Windows Profile setting one can accidentally trigger by pressing a certain combination of keys. This 

causes Internet Explorer to render websites slightly larger or slightly smaller than usual. This affects the size of the 

image that Ticket-It sends to the printer! To fix this, you must reset Internet Explorer’s settings.  

1. Open Internet Explorer, go to Tools > Internet Options, click the Advanced tab, and then click the 

“Reset…” button at the bottom of the Window (just above the Apply button).  

2. You will be prompted to close other programs and warned that certain settings will be lost (usually things 

like saved passwords and browsing history). Accept, and reboot the computer if prompted.  

3. The problem should now be fixed. You will need to “Always allow pop-ups from courierpost.co.nz” when 

prompted after going to the Ticket-It welcome screen or when printing a label, as the previous setting will 

have been lost. 

 

SATO CG412DT: prints 10mm and then jams 

and beeps 

This issue is caused by the printer being in Thermal Transfer printing mode instead of Direct Transfer printing 

mode. To fix: 

1. Browse to the Printers and Faxes / Devices and Printers folder. 
2. Right-click the printer and select Properties / Printer Properties. 
3. Click the Preferences… button 
4. Click the Advanced Setup tab. 
5. Untick thermal transfer. 
6. Click Apply. 

 
Alternatively, try using the Seagull Drivers. Follow the “Other Label printers guide” available on the Help Centre. 
 
 

SATO CG412DT: prints out half a label 

This issue is caused by the printer being in Continuous printing mode instead of Tear Off printing mode. To fix: 

1. Browse to the Printers and Faxes / Devices and Printers folder. 
2. Right-click the printer and select Properties / Printer Properties. 
3. Click the Preferences… button 
4. Click the Advanced Setup tab. 
5. Change Operation Mode and Print Mode to Tear Off. 
6. Click Apply. 
7. Alternatively, try recalibrating the printer. 

http://www.courierpost.co.nz/files/pdfs/faq/label-printer-setup-guide---other-label-printers-n/
http://www.courierpost.co.nz/faq/ticket-it-help/


 

   

SATO CG412DT: will not print or test print 

on Windows 7 64bit 

This issue is caused by Windows 7 sometimes not installing the correct 64bit printer drivers. To fix: 

1. Download the correct drivers from: http://www.satoeurope.com/uk/service-support/printer-drivers.aspx  
2. Extract the driver files. 
3. Install the printer using the ‘Add a printer’ dialogue. When asked to select a driver, browse to the 

extracted driver folder and select SI_ENH.inf from the 64bit folder. 
4. Select SATO CG412DT from the list. 
5. Proceed with rest of installation using the guide from the help centre. 

 
Alternatively, try using the Seagull Drivers. Follow the “Other Label printers guide” available on the Help Centre. 
 
 

The printed image on the label is very small 

or squashed 

This issue has been known to occur with Zebra printers under certain Windows configurations. To fix: 

1. Right-click the printer. 

2. Select Printer Properties. 

3. Click on the Advanced tab. 

4. Click the Print directly to the printer radio button. 

5. Click Apply. 

 

When printing a label, Internet Explorer 

freezes 

This is caused by the wrong version of the ActiveX script being installed. See reinstalling the ActiveX script. 

 

  

http://www.satoeurope.com/uk/service-support/printer-drivers.aspx
http://www.courierpost.co.nz/files/pdfs/faq/label-printer-setup-guide---other-label-printers-n/
http://www.courierpost.co.nz/faq/ticket-it-help/


 

   

Issues with Network printers 

 
Ticket-it considers a locally attached printer (plugged directly into the PC via USB) and a shared or networked 
printer as having different names. This can cause issues. Here is an example: 

 I use my Ticket-It login on PC #1. The printer is locally attached via USB and named Ticket-It-printer. I 

save my printer settings under Administration and print some tickets. 

 I use my Ticket-It login on my neighbour’s PC (PC #2). I try to print labels but cannot, even though 

Ticket-It-Printer is accessible from PC #2 over the network. 

This occurs because Ticket-it cannot find the saved printer ‘Ticket-It-printer’ on PC #2. On PC #2, the printer will 

be referred to as ‘PC #1/Ticket-It-Printer’ instead (the network name of the printer). The alternate printer name 

can be saved as the default printer in Ticket-it and I will be able to print again, but when I move back to PC #1 I 

will need to once again change my settings. 

Solutions: 

 Do not use Ticket-it on PC #1 (usual setup for print-server scenarios) 

 Create a Ticket-It login for use on PC#1 and another one for use on any other computer accessing the 

printer over the network. Each account can have its own specific printer assignment. 

 Consider installing the printer on a completely separate PC (such as a server) that will not be using Ticket-

it. This is the best solution, as the server will be always on, ensuring that the printer will never be 

unavailable to the network. For added convenience, use a Networked printer (one that connects to the 

network directly via Ethernet cable), install it on the server, and share it to all other computers. This way 

the printer can be placed anywhere and be accessible from anywhere. 

 

Quick Fixes 

 If you’re not using a Seagull Driver, try going to Printer Properties, then the Printer Settings tab, and then 

ticking the Always use driver settings box.  

 Using a different driver can solve many problems. If the driver automatically installed by Windows has 

issues, try using the Seagull Drivers (refer to the appropriate instructions available at 

http://www.courierpost.co.nz/faq/ticket-it-help/) 

 Try Recalibrating the printer. 

  

http://www.courierpost.co.nz/faq/ticket-it-help/


 

   

Uninstalling Printer Drivers 

1. Delete any existing print jobs in the queue. Click here if you are unsure of how to do this. 
2. Browse to the Printers and Faxes / Devices and Printers folder. 
3. Right-click the printer you wish to remove and select Delete / Remove Device.  
4. Then, in the same folder, go to File > Server Properties (in Windows 7 you may need to press alt to 

reveal the top menu bar), browse to the Drivers tab, select the driver for your printer (it should be 
named the same as your printer model) and click Delete. Click Okay on any prompts that appear.  

 

Reinstalling the ActiveX 

Sometimes the ActiveX component can become faulty – typically after updating Internet Explorer. This causes the 

‘black box’ issue or prevents printing entirely. To reinstall the ActiveX:  

1. Download this file: http://www.courierpost.co.nz/files/pdfs/faq/ticket-it-activex-installer/ .  
2. Extract the two files within the .zip to your desktop, then double-click SMSX.exe (you may need to run it 

as admin).  
3. Accept all the prompts. If prompted to, restart your PC. If not, restart Internet Explorer and try a test 

print. 

 

Recalibrating printers 

Sometimes printers will print labels incorrectly even with all the correct software settings in place. Generally the 

fix for this is to recalibrate the printer; which forces it to measure the labels and adjust to the dimensions. Doing 

this resolves a number of problems. 

Most Zebra models, including LP2844, LP2844-Z, GK420D, GK420T 

Hold the feed button down until you see the light blink once, then twice quickly in succession, then release the 

feed button. Newer models will feed two blank labels. Older printers will feed several blank labels and then print 

several test labels as well. The printer should stop automatically, but if not, pressing the feed button should end 

the process.  

Older Zebra models such as the TLP2844 

Turn the printer off by flicking the switch on the back of the printer. Hold the Feed button, and then turn the 

printer back on. Release the feed button when the ring of light around the Feed button turns red. The printer will 

feed and print test labels. Press the Feed button twice to complete the process. 

SATO D512 

Turn the printer off. Hold the Feed and Line buttons and turn the printer on. Hold the buttons for about six 

seconds and then let go. Wait until the printer beeps three times, and then turn it off. 

SATO CG412DT 

See the next page for an image explaining how to recalibrate this printer model. 

http://support.microsoft.com/kb/946737
http://www.courierpost.co.nz/files/pdfs/faq/ticket-it-activex-installer/


 

   

 

 

 


